[サブタイプ階層]ダイアログボックス(GDLマスタウィンドウ)

GDLオブジェクトサブタイプについて」も参照してください。

このダイアログボックスは、GDLマスタウィンドウの[サブタイプを選択]ボタンを使用して表示できます([ファイル]→[ライブラリとオブジェクト]→[新規オブジェクト])。

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/SelectSubtype.png 

または、[GDLライブラリ部品の編集]ツールバーからでも使用できます([ウィンドウ]→[ツールバー]→[GDLライブラリ部品を編集])。[作業環境]ダイアログボックスを使用して、ARCHICADのメニューにこのツールバーを追加できます。

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/EditGDLToolbar00100139.png 

サブタイプ階層に名前でリストされている項目は、カラーコーディングされています。

緑は、その項目が配置可能であることを示します。

黒は、その項目を単独では配置できず、マクロ参照としてしか使用できないことを示します。

太字タイプは、項目がサブタイプテンプレートで配置可能であることを示します。

階層で項目を強調表示した場合、下部にその特性が表示され、確認できます。

[名前]フィールドの下の[GUID]は、強調表示されたサブタイプのグローバルユニークIDコードを示します。

GUIDの機能の完全な記述は、ヘルプセンターの該当記事を参照してください。

[選択]:項目のマスタウィンドウを直接に開くには、このボタンをクリックします。

[複製を作成]:このボタンをクリックすると、強調表示されたサブタイプのコピーが同じ特性で作成されます。