特殊結合オプション

このダイアログボックスを表示するには、[ファイル]→[相互運用性]→[DXF-DWG]→[特殊結合オプション]を使用します。

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/SmartMergeOptions.png 

このコントロールを使用して、DXF/DWGファイルの特殊結合過程を設定できます。

詳細は、「双方向変換(特殊結合)」を参照してください。

既存の設定を選択するか、または新規の設定を作成できます。設定ファイル(.mcf)は、[アドオン]のフォルダにあります。

ボタンを使って、設定ファイルも複製、名称変更、削除できます。さまざまな必要に合わせて設定を異なるファイルに保存できます。DXF/DWGファイルを結合する時は、ARCHICADは最初に、DXF-DWG Config.tmlファイルの#MERGECONFIGセクションで定義された.mcfファイルを検索します。このセクションが使用されていない場合、ARCHICADは引き続き、dxf.mcf設定ファイルとデフォルトの.mcfファイルを検索します。

上記のファイルがない、あるいは他の.mcfファイルを選択する場合は、[ファイル]→[相互運用性]→[DXF-DWG]→[特殊結合オプション]ダイアログボックスでいつでも選択できます。

設定を見れば、DXF/DWG図面を平面図に結合する時に、何が起こるかわかります。

結合過程は、表示されているロックされていない要素にだけ作用するので、変更させない要素の場合は、非表示にするかロックします。

[現在の設定のルールを編集]の横にある小さな矢印をクリックすると、設定の詳細を確認または編集できます。このリストにあるルールは編集可能で、最大ルール数は16個です。ルールは、条件部分と1個以上のアクションからできています。DXF/DWG図面からの要素がルールの条件に一致した場合に、この要素でルールの操作が実行されます。

リストのどの条件にも一致しない要素は無視されます。

ルールの追加/削除

[新規ルール]ボタンによって、新規の空きルールがリストの最後に追加されます。このルールの条件と操作は未定義です。条件を完全に定義し、必要な数の操作を設定すると、ルールが有効になります。

ルールの行を選択して、[ルールの削除]ボタンをクリックすると、ルール全体を削除できます(区切り線は選択できません)。

ルールの編集

条件を編集するには、リスト内の行をクリックし、その次に表示されるポップアップウィンドウで、他の条件を選択する必要があります。操作を編集するには、変更するアクションの行をクリックして、ポップアップウィンドウから他の有効な操作を選択します。ルールから操作を削除するには、そのルールを選択して、[操作の削除]ボタンをクリックします。ルールには、少なくとも1つの操作が必要です。したがって、最後の1つは削除できません。[操作の追加]ボタンによって、選択した操作の後ろにその操作を挿入します。最初は、ルールは定義されていないので、その有効値を設定する必要があります。

操作は順番に読む必要があります。これは、実行順序が不適切になる場合があるからです(例:最初に元の位置に壁を複製し、次に複製した元の項目を移動する場合と、最初に元の項目を移動し、次に新規の位置にその項目を複製した場合とでは、結果が異なります)。通常、操作はARCHICAD平面図の要素に適用しますが、必ずしもそうとは限りません。要素の複製後の操作は、複製に対して適用されます。[結合したファイルから輪郭を描く]後の操作は、DXF/DWGファイルに保存された[略図化された図面]に対して適用されます。

「図略化された図面」の詳細については、「特殊結合の追加情報」を参照してください。

特殊結合の追加情報

[結合]機能を理解するために、ここで、詳細ごとに内容を確認していきます。

ARCHICADでは、次の操作を実行できます。

新しい要素を追加できます。既存の要素をコピーして要素を作成した場合でも、その要素は新しいユニークIDを取得するので、新しい要素といえます。

以前に作成した要素を変更できます。つまり、要素の移動やストレッチができます。また、面積パラメータの変更だけを行うことも可能です。壁に窓やドアを挿入したり、それらを変更したりすると、壁の修正日が変更されるため、壁が変更されます。この場合は、DWG/DXFファイルをARCHICADに結合し直した時に、ARCHICADの元の壁モデル要素の隣に「輪郭図面」を表示できるだけになります。

全てを削除できます。

AutoCADユーザーの協力会社は、DWGファイルで以下の操作を実行できます。

新しい要素を追加できます。

エクスポートされた項目を移動、回転、またはミラーできます。項目のストレッチもできますが、これは推奨されません。結合機能で処理されるのは、サイズを保持した変換だけです。

要素を削除および複製できます。

しかし、図面の項目(Autodeskの用語では図形といいます)が自分達がエクスポートしたものか、他のユーザーが作成したものか、あるいは、他のユーザーが古いカテゴリの項目に何を実行したか、どうすればわかるでしょうか。

Autodeskは、各図形にカスタムデータ(拡張図形データといいます)を追加する手段を用意しています。

これにより、エクスポートする各要素の画像と一緒にARCHICAD固有の情報を保存できます。

このような要素は、1つのAutoCAD図形(例えば、円)で表すことができる単純なものでも、複雑なもの(例えば、最低2本の線と1つのハッチングとして描かれる壁)でも可能です。

複合化要素を単位として処理するには、この要素をブロック(ARCHICADのライブラリ部品のようなもの)に結合する必要があります。

結合では、AutoCADユーザーが平面図で行った変更を組み込むため、平面図に元の変更されていない要素がある必要があります。これは、以下の最小限の情報だけが保存されることを意味します。

(ARCHICADの)ユニークID、および要素のタイプ

図形が移動、回転、またはストレッチされた場合にAutoCAD(またはもう一方のプログラム)が変換する3つの座標。もう一方のプログラムがAutoCADでない場合も、同様に実行される必要があります。

要素のレイヤーのAutoCAD ID。AutoCADユーザーが要素を別のレイヤーに移動したかどうかをARCHICADが検出できるようにするためです。

最初にエクスポートされた要素のAutoCAD ID。元と複製を区別するためです。これは、別の要素への結合過程で行われます。

DWGのエクスポート後に平面図に作成された要素:操作なし

AutoCADユーザーが追加した図形(ARCHICADで生成された要素の複製は含まれません)は、保持しておく必要性が高いので、平面図に追加されます。
図面にエクスポートされた要素(他のプログラムによって変更されていることも、されていないこともあります)の場合、問題は、あなたとAutoCADユーザーがこの要素を同時に変更または削除できてしまうということです。この状況は、次のような表で説明できます。

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/Matrix.png 

ここで、それぞれの数字とアルファベットは以下を表しています。

1:ARCHICADユーザーが要素を未変更のまま

2:ARCHICADユーザーが要素を変更

3:ARCHICADユーザーが要素を削除

A:AutoCADユーザーが要素を未変更のまま

B:AutoCADユーザーが要素を変更

C:AutoCADユーザーが要素をコピー

D:AutoCADユーザーが要素を削除

1/Aの場合は単純です。だれも要素を変更しなかったので、要素は未変更のままです。

1/B:平面図から要素の元の状態を取得できるので、問題なく変更内容を適用できます。

1/C:1/Bと同様に、元の要素のコピーに適用されるだけです。

1/D:要素は削除されます。

しかし、要素を変更した(2)か、削除した(3)場合、結果は大きく異なる可能性があります。AutoCADユーザーが同じ場所に残した壁を移動して(2/A)管を取り付けた場合、管は何もないところに表示されます。

あるいは、両者とも要素を移動した場合(2/B)、移動は完了していますが、平面図に元の位置が保持されていないため、AutoCADユーザーの移動を適用する方法が不明です。

この問題に対処する唯一の方法は次のとおりです。AutoCAD図面には目的の変更を反映する要素画像が含まれています。この画像(「輪郭」)は平面図に直接描画することができるので、少なくともAutoCADユーザーが何を実行しようとしたのかがわかります。その後で、何を実行するかを手動で決定できます。

注記:要素がAutoCADでスケールされた場合、図面に輪郭が描かれ、スケールされた要素は単線、円弧、および塗りつぶしとしてARCHICADに表示されます。

3/Dは単純です。両者とも要素を削除するつもりでした。既にこれを実行しているので、何もすることはありません。

結合は設定可能であることを忘れないでください。上記の解決策は提案にすぎません。

他にも多くのことを実行できます。

元の要素を別のレイヤーに移動できます。

AutoCAD図面からの要素を別のレイヤーに移動できます。

一連の操作の任意の時点で確認を求めるようにARCHICADに要求できます。これは、変更内容を検討し、結合操作を決定できるよう、ARCHICADによって問題の要素がズームされることを意味します。

使用できる操作は、以下のとおりです。

<レイヤー>レイヤーに要素を配置:平面図の要素をDXF/DWGファイルで指定されたレイヤーに配置します。

「削除した」レイヤーに要素を配置

「編集した」レイヤーに要素を配置

「コピーした」レイヤーに要素を配置:アドオンによって作成された特殊レイヤーに要素を配置します。これは、AutoCADユーザーが編集した要素を分離したい場合に便利です。

要素の複製:要素のコピーを作成します。

要素の変換:DXF/DWGファイルの要素に適用された変換(移動、回転、ミラー、または必要な場合はレイヤーの変更)を実行します。レイヤーの変更は、「要素をレイヤーに配置」操作も有効な場合にのみ実行されます。サイズ変更操作は無視されます。

要素の削除:平面図から要素を削除します。

結合したファイルから輪郭を描く:平面図に要素の「輪郭図面」を配置したい時、または他の操作を選択できない時に設定します。これは、ARCHICADで元の要素が変更または削除された場合です。つまり、要素はARCHICADの2D要素のセットとしてAutoCAD図形から生成されます。