[メニューのカスタマイズ]ダイアログボックス

[オプション]→[作業環境]→[メニュー]ダイアログボックスでは、ARCHICAD内の全メニューのコンテンツおよび配置をカスタマイズできます。コマンドまたはメニューは全て、別のメニューに追加したり削除したりできます。また、メニュー内のコマンドの並び順も自由にカスタマイズできます。

例外:コンテキストメニューはカスタマイズできません。

必要に応じて分割バーを移動させ、ダイアログボックスのフィールドの幅を変更します。

[メニューのカスタマイズ]パネル

ダイアログボックスの左側(アプリケーションコマンドとメニュー)には、ARCHICADの全てのコマンドとメニューがリスト表示されます。リストは、[現在のメニュー構造]、[テーマ別の全てのコマンド]、[アルファベット順の全てのコマンド]、[アルファベット順の全てのメニュー]、[全ての新規コマンドをアルファベット順]の5つの形式のいずれかで表示できます。リストの最後の項目は区切りバーです。

注記:2つの全てのコマンド形式のいずれかで表示する場合、表示(つまり、クリックして右にドラッグ)できるのは、右側の[メニューの構築または編集]リストで特定のメニュー(メニューバーに対して)を選択した場合だけです。

[アルファベット順の全てのメニュー]について説明します。このリストには[ファイル]や[編集]などメニューバーに追加した通常のメニューだけではなく、[付属部品]といった、コマンドの集合を含むメニューも含まれます。このメニューは、メニューバー内に、サブメニューとして別のメニュー内に、またはツールバー内に配置できます。

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/CustomMenu1.png 

リストの右側(このメニューの構築と編集)には、メニューバーの現在の設定か、現在構築中または編集中のメニューが表示されます。

注記:編集中のメニューが表示されるのは、その時点での現在のウィンドウと同じタイプ(テキストまたはグラフィック)のウィンドウのみです。

詳細は、「ウィンドウタイプ」を参照してください。

[このメニューの構築と編集]の下にあるポップアップにはメニューの一覧(コマンドはなし)が、各メニューへのパスと一緒に表示されます([ファイル]→[外部参照]など)。

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/CustomMenu2.png 

構築または編集したいメニューを一覧から選択してください。メニューは、インターフェイスに現在あるものが表示されます。作業環境に入っていないメニューは、リストの最後にまとめて表示されます。

[メニューオプション]:メニュー管理のためのオプションを[新規メニュー]、[メニューの名前を変更]、[メニューを削除]、[メニューを複製]から選択します([新規メニュー]では、選択したメニュー内のサブメニューが作成されます)。

注記:メニューバーを選択すると、このコントロールがメニューバーオプションに変更され、使用できるコマンドは[新規メニュー]だけになります。このコマンドでは、新規メニューが作成されてARCHICADメニューバーに追加されます。

リストウィンドウ:リストウィンドウの右側には、選択したメニューのコンテンツが表示されます。メニューのコンテンツには、コマンド(左側の[全てのコマンド]リストから移動する)またはメニュー(左側の[全てのメニュー]から移動する)があります。メニュー内にあるメニューは、アイコンで示されます。

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/MenuMenuicon00131.png 

このアイコンをクリック(または名前をダブルクリック)してメニューを開くと、内容を編集できます。

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/CustomMenu4.png 

リストウィンドウの右側にあるメニュー階層で1レベル上に移動するには、[1レベル上]アイコンをクリックします。

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/UpLevelIcon.png 

この右側のリストウィンドウでは、次の操作を行うことができます。

メインのARCHICADメニューバー内のメニューを並び替え

[選択内容を追加]ボタンや[削除]ボタンを使用して、コマンドやメニューを他のメニューに追加または削除

上下の矢印で移動してコマンド/メニューの順序を変更

分離線はメニュー内で項目をグループごとにまとめるのに便利な機能で、上下の矢印で位置を自由に変更できます(新しい分離線を挿入するには、リストの左側の下からバーを移動します)。

[詳細オプション]パネル

[メニュー項目の変更]:右の列からメニューやコマンドを選択すると、このチェックボックスが有効になります。

このボックスをチェックすると、選択した項目(例えば、[新規作成とリセット])とその上にある項目(この場合[新規作成])が入れ替わります。入れ替わる項目は、上の項目よりインデントされて表示されます。メニューには、入れ替える2項目のうち、どちらか片方が表示されます。

重要:入れ替える項目のショートカットは、片方の項目のショートカットに修飾キーが付いている以外は同じものにしてください。例えば、[新規作成]のショートカットが「Ctrl+N」であれば、[新規作成とリセット]のショートカットは「Ctrl+Alt+N」とします。

両者を入れ替えるには、修飾キー(この場合Alt)を押します。