ライブラリ部品を開いて編集する

1.[ファイル]→[ライブラリとオブジェクト]→[オブジェクトを開く]に移動します。

2.[ライブラリ部品を開く]ダイアログボックスで、ライブラリ部品を選択します (チームワークでライブラリ部品を確保する必要があります)。

3.編集可能なGDLオブジェクトの場合:[開く]をクリックしてGDLオブジェクトエディタを開きます。(編集ウィンドウがまだ確保されていない場合は確保して)、必要な編集を行います。

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/040-elementsvb/OpenLibPartTW.png 

GDLオブジェクトエディタ」を参照してください。

4.編集できないGDLオブジェクトの場合(リンクライブラリに配置されている場合など):[表示]をクリックして、GDLオブジェクトエディタでその設定を確認します。ここでオブジェクト設定を修正することはできません。ライブラリマネージャーを使用してライブラリ部品をローカルフォルダに抽出し、それを編集してプロジェクトに再ロードすることができます。

5.別のタイプの編集可能なライブラリ部品の場合: ドロップダウンをクリックして、選択したライブラリ部品を開いて編集するアプリケーションを選択します。

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/040-elementsvb/OpenImageLibPart.png 

6.ウィンドウを閉じて編集内容を保存します。

チームワークユーザーの場合、送信/受信を実行すると即座に編集済みのBIMcloudライブラリデータを使用してプロジェクトが更新されます。

単独ユーザーの場合、ライブラリマネージャーから再ロードと適用を実行すると即座に編集済みのBIMcloudライブラリデータを使用してプロジェクトが更新されます。

BIMcloudライブラリのライブラリ部品にアクセス

以下の場合にのみ、BIMcloudライブラリのライブラリ部品にアクセスできます。

オブジェクトを確保している場合

アクセス権限に「ライブラリ部品-削除/修正」が含まれる場合

ライブラリ部品が通常のフォルダ内にあり、PLAまたはLCFファイルではない場合

注記:ライブラリマネージャーで、PLAおよびLCFファイルのコンテンツがツリービューに展開されて表示されます。コンテンツ(ライブラリ部品)にアクセスするには、項目を選択し、[複製]または[エクスポート]を選択してフォルダの場所を指定します。フォルダが開き、コンテンツを編集できるようになります。

上記以外の場合、このようなオブジェクトのオブジェクトエディタウィンドウは読み取り専用になります。

配置済みGDLオブジェクトの編集

平面図に配置済みのGDLオブジェクトのパラメータスクリプトを編集するには、オブジェクトを選択してから[ファイル]→[ライブラリとオブジェクト]→[オブジェクトを開く]を選択します。

表示されるGDLオブジェクトマスタウィンドウを使用して、単一の環境内で既存のオブジェクトを修正できます。このウィンドウでは、GDLオブジェクトのパラメータ、構成要素、記述項目、スクリプトおよび2Dシンボルの追加または編集を行うことができます。

詳細は、「GDLオブジェクトエディタ」を参照してください。