ホットリンクモジュールの内容の編集

注記:ARCHICAD 22 レギュラー版のみ

このセクションでは、次の3つのワークフローについて説明します:

別途ARCHICADでモジュールを編集

ホットリンクを解除(埋め込み要素)

ホットリンクをファイルとして保存…

別途ARCHICADでモジュールを編集

IFC/Rhinoベースのホットリンクモジュールでは使用できません。

1.以下のいずれかを実行します。

ホットリンクモジュールマネージャーで、[ホットリンクソース]リストから目的のソースファイルを選択し、 [別途ARCHICADで開く]をクリックします。

配置されているホットリンクを選択し、コンテキストメニュー[ホットリンクモジュール]→ [別途ARCHICADでモジュールを編集]を使用します。

2.必要に応じてソースファイルを編集し、保存します。

ヒント:配置済みモジュールの平面図コンテキストを表示しながら、別途開いたARCHICADでそのソースを編集したい場合は、[参照]機能を使用します(モジュールの内容を編集中にホットリンクモジュールの内容を表示」を参照)。

3.最初の(ホスト)プロジェクトに戻ります。

4.[ホットリンクモジュールマネージャー]に移動します。ホットリンクソースリストで、編集済みのモジュールのホットリンクソースのステータスが修正済になっていることを確認してください(必要に応じて[ステータスを更新]をクリックします)。

5.[更新]をクリックします。

6.[OK]をクリックして、モジュールの全てのホットリンクで更新を実行し、ホットリンクモジュールマネージャーを閉じます。

注記:チームワークでは、更新を行うにはホットリンクモジュールマネージャーでホットリンクソースを確保する必要があります。

ホットリンクを解除(埋め込み要素)

このコマンドを使用してこのホットリンクを解除し、要素をホストプロジェクトに埋め込みます。

これは、ホットリンクを配置してある場合に使用しますが、ここでは、そのソースファイルを介してではなく、ホストプロジェクトでローカルで編集する場合を考えます。

例:標準客室のモジュールの複数のホットリンクを配置しました。それらの客室のうちの1つが平面図に収まりません。この場合、その1つのインスタンスのホットリンクを解除し、その特定の場所に合わせてその内容を編集することができます。

1.平面図でモジュールを選択します。

2.コンテキストメニューまたはホットリンクの選択設定から、[ホットリンクを解除(埋め込み要素)]を使用します。

または、[ファイル]→[外部参照]→[ホットリンクを解除(要素を埋め込む)]を使用します。

注記:特定のモジュールの全ての配置済みホットリンクを解除するには、ホットリンクモジュールマネージャーから[リンクを解除]コマンドを使用します。

注記:チームワークでは、[ホットリンクを解除]機能は使用できません。代わりに、ホットリンクモジュールを分解することができます(チームワークでのホットリンクモジュールインスタンスの分解」を参照)。

3.必要に応じて要素を編集します([編集]→[グループ化]→[グループの一時解除]を使用して編集を有効にします)。

ホットリンクをファイルとして保存…

ホットリンクモジュールマネージャー、および配置されたホットリンクモジュールのコンテキストメニューから使用できます。

このコマンドを使用すると、ホットリンクモジュールの要素を新しいファイルとしてモジュール形式(.mod)で保存できます。

例:標準客室(客室A)のモジュールの複数のホットリンクを配置しました。客室のレイアウトの1つ(客室Bと呼びます)を変更しますが、その際、その要素をホストプロジェクトに埋め込まないものとします(後で客室Bのホットリンクを追加で配置する必要があるため)。

1.ホットリンクを選択します(ホットリンクモジュールマネージャー、または平面図で)。

2.[ファイル]→[名前を付けて保存]または[ホットリンクをファイルに保存]コマンドを使用します。

3.[選択をホットリンクされたモジュールファイルと置き換える]ボックスをオンにします。

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/080-collaboration/SaveHotlinkasFile.png 

元の客室Aモジュールとは無関係に編集できる、別個の新しいモジュール(ルームB)を作成しました。