IFCと参照を使用した構造と意匠モデルの比較

by GRAPHISOFT · 最終更新日: 2015年12月11日

 構造モデルと意匠モデルをIFCと参照機能を使用して比較する

構造解析、計算の結果によっては、構造担当のエンジニアより構成要素のサイズや形状の変更をを提案される可能性があります。PDFやDWGといった様々な種類の2次元の構造図面も追加されるでしょうが、ArchiCADは3Dの構造モデルを参照として開くことができ、IFCファイルとして保存されます。さらに、元のモデルと参照のモデルとの違いは、ArchiCAD内の参照と呼ばれる機能で表示させることができます。

この文書では以下のモデルを比較します:

  • 意匠モデル(オリジナル)
    耐力構造要素は単純化されたオリジナルのArchiCADモデル(躯体表示を参照ください)

そして

  • 構造モデル(参照)
    構造エンジニアによる変更を含んだインポートされたIFCモデル。

注意:参照は平面図や断面立面などの3Dモデルの2D表示でのみ動作します。この機能では同一画面で2つのビュー/図面を比較できます。

推奨されるArchiCADで比較する手順

1. 参照するIFCモデルをArchiCADで開きます([ファイル]>[開く])。

2. 新しくレイヤーを作成します(例.“参照”レイヤー;[ドキュメント]>[レイヤー]>[レイヤー設定])、そしてそちらにそのモデル(インポートされた構造要素)を割り当てます。

3. 参照モデルをPLNとして保存します。

4. オリジナルのArchiCADモデルを開きます。

5. オリジナルモデルに埋め込まれたモジュールとして参照モデルを挿入します。
compare-models-1.png
ホットリンクモジュールとして配置するコマンド([ファイル]>[ファイル特殊])を使用し、手順3で保存したPLNファイルをホットリンクとして選択します。参照モデルはマスターレイヤーにセットされたレイヤー(デフォルトはモデルのユニット – モジュール)に配置されます。
オリジナルと参照を比較するには、オリジナルと同じ位置に挿入したモジュールを配置することをお奨めします(必要であれば、ドラッグのコマンドを使用します)。

6. オリジナルのモデルのレイヤーと埋め込まれたモジュールのレイヤーの2つのレイヤーセットを作成します。例:

  1. “オリジナル”レイヤーセット:
    モジュールのモデルユニットと参照レイヤーを非表示にします。
    compare-models-2.png

  2. “参照” レイヤーセット:
    全てのレイヤーを非表示にし、モジュールのモデルユニットと参照レイヤーのみ表示します。
    compare-models-3.png

7. 変更を確認したい箇所で断面を作成します。

8. オーガナイザで主なプロジェクトビューの2つのグループ(フォルダ)を作成します(例.オリジナルと参照のビューフォルダ)。
compare-models-4.png

9. [ビュー設定]で、適切なビューにオリジナルと参照のレイヤーセットを関連付けます。
compare-models-5.png

10. 参照機能を使用してオリジナルと参照を比較します。参照パレットにアクセスし、[ウィンドウ]>[パレット]>[参照]を選択します。参照は2つのビューで動作します:

  1. 現在:
    現在作業してる実際のモデルや図面。

  2. 参照:
    現在のコンテンツの上部もしくは下部に任意に配置されたもの。同じスクリーンに複数のモデルビュー/図面を下敷きのようなものとして簡単に比較できます。


例として、オリジナルと参照モデルの平面図と断面図を比較するために参照がどうように動作するのかを見てみましょう。

平面図

ナビゲータ – ビューマップにてオリジナル(現在)のフロアを有効にします。同じフロアビュー(名前)を右クリックして「参照として表示」を選択します。参照オブジェクトは特定の色(例.次の画像では赤)で表示されます。

compare-models-6.png

断面

同様の手順で2つのモデルの平面図で断面を比較を実行します。

compare-models-7.png

関連情報

参照パレットの他の機能や詳細はArchiCADヘルプを参照してください。

Related content

IFCプロパティ

IFCプロパティは、IFCエンティティに割り当てられた追加の(大多数はIFCタイプ固有の)パラメータです。IFCプロパティは、「IFC…

IFCデータ

バージョン8.1~11のArchiCADプロジェクトのIFCデータは、プロジェクトをArchiCAD 19に移行したときに失われます。

IFCオプション

IFCオプション([ファイル]→[ファイル特殊]→[IFC 2x3])で定義した設定は、IFCデータの作成および結合方法にも影響します。 IFCマネージャーツリービュー…

IFCスキーム設定

IFC 属性、プロパティおよび分類参照データは、スキームと呼ばれるファイル(.xmlファイル)に保存できます。 IFCデータのマッピング以外に、スキームを使用してIFCデータにルールを割り当てることができます。IFCデータ値を持つArchiCADパラメータや数量値がマッピングされます。マップルールは、スキームの.xmlファイルにも保存されます。 [IFCスキーム設定]コマンド([ファイル]→[ファイル特殊]→[IFC 2x3])を使用して、スキームを管理します。…

IFCデータの作成と編集

注記:チームワークでは、IFCマネージャー内のIfcProjectや、IfcBuilding、IfcSite、割り当て製品タイプを確保して変更できます。モデル要素(IfcWall、IfcColumn、IfcBeamなど)のIFCプロパティは、その要素を他のユーザーが確保していない場合のみ、IFCマネージャーから変更できます。 スキームデータ スキーム(IFCスキーム設定)で設定した属性やプロパティ、分類参照エンティティには、任意に割り当てられた値あるいは派生した値を付けることができます。…