3Dモデルに2D平面図を重ねる方法

by GRAPHISOFT · 最終更新日: 2015年12月11日

このトピックでは、2Dの線図面を3Dモデルに配置して、2D平面図ビューが生成された切断面の垂直位置に正しく調整する方法について解説します。これにより、現在の3Dモデルを2D表現と比較することができます。手順は以下の通りです:

  • 2D重ね合せ モデル

ステップ1: 平面図の設定を確認

平面図で、モデルに重ねたい2D平面図のフロアへ移動します。
必要なレイヤーセット、モデル表示オプションセットを選択します。また、平面図の切断面設定も確認します。

  • 2D-superimpose-plan
    TIP:設定したビューを保存することをお勧めします。これによりプロジェクトが変更されても同じ手順を後で再度行うことができます。

    2D重ね合わせ

ステップ2: DWGとして平面図を保存

[ファイル→名前を付けて保存]を使用して、平面図をDXFあるいはDWGファイルとして保存します。

ステップ3: DWGをオブジェクトとして開く

[ファイル→ライブラリとオブジェクト→オブジェクトを開く]メニューコマンドを使用して、保存されたDXF/DWGファイルを開きます。DXF/DWGファイルを開くと、結果となるArchiCADライブラリオブジェクト内の水平X-Y面上の3D線として線が保存されます。ライブラリオブジェクトの3Dビューを開いて確認してください。
2D重ね合せGDL

ステップ4: オブジェクトを保存

[ファイル]→[名前を付けて保存]にて新しい名前でライブラリオブジェクトを保存します。

ステップ5: 保存したオブジェクトを平面図に重ねる

平面図に戻って、オブジェクト設定ダイアログに移動します。保存したオブジェクトが選択された状態になります。
プロジェクトにオブジェクトが配置される垂直高さを設定します。これは、DXF/DWGファイルが保存されたビューの平面図の切断面のレベルと同じにします。

[OK]をクリックして変更を確定します。平面図で、オブジェクトを配置します。配置後、モデルの2Dとオブジェクトの2Dが正しく重なるように移動して下さい。

  • 2D重ね合せ-オブジェクト設定

ステップ6: 3Dビューで表示を設定

断面/立面やモデルビューを確認するためのレイヤーセットを選択します。また、[表示]→[3D表示要素]→[3Dで要素をフィルタ]ダイアログボックスで全ての必要な要素タイプが表示されていることを確認してください。

同じダイアログで、表示するフロアを選択してください。2Dを重ねるフロアより上のフロアは非表示にします。

ステップ7: 3Dでモデルを表示

プロジェクトの3Dビューを開きます。

  • TIP: 3DウィンドウはOpenGLモードのシェードビューオプションに設定してください。インターナル3Dエンジンでは、3D線が表示されないからです。
    2D平面図が3Dモデルに重なって正しい空間位置に表示されます。

  • TIP:より正確な比較を行うために、2D図面を重ねている高さで3Dモデルに3D切断面を適用します。正確な比較を行うには重要です。以下のことを行います:

    • [表示]→[3D表示要素]→[3D切断面]に移動します。モデル内の2D線オブジェクトの場所が分かるはずです。
    • 水平切断面を2Dオブジェクトより上部(例えば1cm高く)設定します。2Dオブジェクトが切断面でカットされないよう同じ高さに設定しないようZ値の設定フィールドを使用します。
    • [OK]をクリックして変更を確定します。また、[表示]→[3D表示要素]→[3D切断]オプションを確認して、3Dの切断を有効にしてください。モデルが2Dオブジェクトが重なった高さで切断されます。
  • 2D重ね合せ 詳細

Related content