DXF-DWGトランスレータの設定

by GRAPHISOFT · 最終更新日: 2015年12月11日

[ファイル]>[ファイル特殊]>[DXF-DWG変換設定]

エクスポート中に変換設定をクリックすると、以下にフィールの内容を確認、編集することができます、主に6つのグループがあります:

  • 図面単位
  • 開くオプション
  • 保存オプション
  • 属性
  • その他
  • カスタム機能

図面単位

  • ArchiCADでのDXF/DWGの1図面単位: DXFやDWGにエクスポート/インポートする際には、ARCHICADが正しくデータを解釈するようにサイズと距離の変換を設定する必要があります。
  • DXF/DWGファイルの図面単位定義を使用: このチェックボックスを有効にするとARCHICADが元のDXF/DWGファイルの図面単位の定義を使用します。
  • もしそのような元の定義がない場合、もしくは再設定したい場合、図面単位を標準的な図面単位(1メートル、1ミリメートル、1インチ、1フィート)の項目から選択します;もしくはカスタム単位(ミリメートルまたはインチ)を指定します。

DXF/DWGファイルを開く際に、AutoCADで書かれた要素をご自身の見たい正しい比率にスケールを設定します。これは矢印やシンボル線種、シンボル塗りつぶしに適用されます。

テキストと矢印をインポートする際のスケール率:以下の3つから選択できます:

  • 変換とごとに、個別のスケール率を設定
  • 全ての変換で、固定のスケール率を使用
  • 常に、現在の平面ウィンドウで設定されたスケール率を使用

開くオプション

開くオプション

DXF/DWG変換設定内に設定ダイアログボックスがあります。

  • AutoCADブロックの変換方法で「ライブラリ部品」を選択すると部品内の3Dデータに関するオプションが追加されます
  • 寸法の変換方法
  • AutoCADハッチブロックをインポート
  • 埋め込み図面としてビューポートをインポート
  • 「ライブラリ部品として開く」場合のAutoCAD図面の3Dデータ変換
  • ARCHICADに変換される要素をレイヤー別にフィルタ

 

  • 平面図として開く: AutoCADブロックの変換方法:
    • 2D要素
    • グループ化された2D要素
    • ライブラリ部品
  • 寸法の変換方法:
    • 線とテキスト: 寸法図形からは寸法を作成せずに、AutoCADと同様の外観(矢印、色、テキスト位置)で変換されます。
    • 個別寸法: AutoCADファイル内の全ての寸法はARCHICADの寸法に変換されます。注記: ARCHICADとAutoCADの寸法の見た目の特長が異なる場合があります。見た目の全ての特徴が変換中に再現できるわけではありまsねん。最も大きな違いは、矢印にあります:ARCHICADは固定の矢印が1つありますがAutoCADでは独自のセットをデザインできます。
    • 連続寸法: AutoCADでは、個々の2点寸法しか利用できません。(連続寸法のように見える寸法セットを作成するひつようがあります)
  • 連動寸法(該当する場合): AutoCAD の以前のバージョンの連動寸法は、ArchiCAD と連動方法が異なっていました。つまり、他の要素のホットスポットに貼り付けられていました。このチェックボックスをオンにすると、アドオンによって、既にインポートされている要素の中から処理された寸法を連動させる対象が検索されます。これには時間がかかるので、デフォルトでは、要素上にホットスポットを作成し、このホットスポットに長さ寸法を連動させます。
  • AutoCADハッチブロックをインポート: このボックスをチェックすると、AutoCAD 塗りつぶしが個々の線の名前の付いていないグループ(ハッチブロック)に変換されます。これは、ArchiCAD では塗りつぶし種類として認識されません。AutoCAD バージョンR14 以降のバージョンのファイルをインポートすると、ハッチがArchiCADの塗りつぶし種類に変換されます。
  • 埋め込み図面としてビューポートをインポート: DXF/DWG ファイルをArchiCAD で開いた後に、Autocad ビューポイントを埋め込み図面としてインポートすることが確実な場合は、このチェックボックスをオンにします。このボックスをチェックしない場合は、ビューポートがArchiCAD ビューに変換されます。
  • 変換する画像形式: 変換する画像に使用するファイル形式を選択します
  • ライブラリ部品として開く / 3Dソリッド、リージョンおよびボディーをGDLオブジェクトに変換:
    • バイナリ3D: バイナリ情報として3D情報を格納
    • GDLスクリプト: GDLスクリプト内に3D情報を格納

3D データを処理する場合は、[バイナリ3D]を選択することをお勧めします。3D ビューを生成するたびにスクリプトを再コンパイルする必要がない場合は、この方が早く処理できます。[オブジェクトを開く]コマンドはDXF/DWGファイルに含まれている全ての3Dデータを取得する唯一の方法です!

  • 部分オープンを有効

このボックスをオンにして、トランスレータの一部として保存すると、ArchiCAD で開く/結合/ 外部参照を行うDWG ファイルの要素をレイヤー別にフィルタできます。

この場合、[ファイル]>[DWG/DXFファイルで開く]または[結合]、 もしくはXREFをアタッチをした場合、DWG/DXFを部分的に開くダイアログボックスが表示され、元のファイルのレイヤーセットとレイヤーの状態がリストされます。ARCHICADプロジェクトに含めたくないレイヤーはチェックを外します。

  • 3Dソリッド、リージョンおよびボディーをGDLオブジェクトに変換

このチェックボックスをオンにして、ArchiCAD でファイルを開く際、リストの項目をGDL オブジェクトに変換します。


保存オプション

  • SaveSaveOptions.png

  • ファイル形式: AutoCADの保存したいバージョンを選択します。

    • AutoCAD 2000, 2002
    • AutoCAD 2004, 2005, 2006 (デフォルト)
    • AutoCAD 2007
    • AutoCAD 2010 特殊結合機能は全てのオプションで利用可能です。 注意: AutoCAD 2005のファイル形式はAutoCAD 2004形式と同じです。
  • 画像を変換:

    • 画像の元の形式:これはデフォルトのオプションで、この場合hは変換せずに配置されます。AutoCADに推奨されていれば画像はオリジナルの形式のまま保持されます。;推奨されないファイル形式はTIFF形式に変換されます。
    • AutoCAD画像形式に強制出力:このボックスにチェックがあると、画像形式の一覧は選択したAutoCADバージョンが読み込む事ができる画像形式が利用できます。残りの選択は使用不可になります。
  • テンプレートファイル: ArchiCADからAutoCADにエクスポートする際はいくつかの項目は自動的に有効にはなりません。例として、ArchiCADでは、レイヤーはカラーや線種がありませんが、AutoCADにはあります。これらの変換設定の対策としてはテンプレートを選択することです。テンプレートファイルはいくつかの属性が作成されているDXF/DWGファイルです。DXF/DWGのエクスポートでテンプレートが選択されている場合、各要素はそのテンプレートファイルと同様のレイヤーのカラーと線種に設定されます。テンプレートファイルはそのファイルのレイヤー名を提供するので、入力する必要がありません。これにより変換テーブルの作成の手助けとなります。テキスト変換テーブルも同様です。このテンプレートファイルは協力会社より提供されるかもしれません。協力会社にDXF/DWGファイルをエクスポートした後、彼らはそれを開いて変更し、(例.レイヤー、ペン等)、そして次回に使用するテンプレートファイルとしてなり、この協力会社にエクスポートされます。

  • 図面の保存先:

    • ペーパースペース Block図面: レイアウト上に描画される全ての要素、図面データも同様に、AutoCAD図面のペーパー空間に保存されます。全ての図面はAutoCADのブロックに変換されレイアウトに配置されます。これらのブロックはクリップされ、レイアウト上に表示される部分のみがAutoCADのペーパー空間に表示されます。レイアウトを完全に再現するために、このオプションを使用すると、結果としてAutoCADのモデル空間の図面は完全に空白となります。
      注意: ArchiCADの平面図が既に図面としてレイアウトに配置されている際、平面図錠のライブラリ部品、ゾーン、ドア/窓がインテリジェントAutoCADブロックに変換されるのは、それらの図面の状態が図面マネージャで「OK」の状態(つまり、更新された状態)の時だけです。

    • ペーパースペース ビュー一部:レイアウトに手動で作成された図面要素が、作成されたAutoCAD図面のペーパースペースに保存されます。レイアウトの画像は、AutoCAD図面のペーパースペースで再構築されます。レイアウトに配置された図面は、まずレイアウト上の図面の配置ポリゴンによって切り落とされ(切り落とし済みの領域の要素と要素内部の一部だけがエクスポートされることを意味する)、さらにDXF/DWG形式で保存されます。
    • ペーパースペース ビュー全体: レイアウトに作成された図面要素が、作成されたAutoCAD図面のペーパースペースに保存されます。レイアウトの画像は、AutoCAD図面のペーパースペースで再構築されます。レイアウトに配置された図面は、その全体がDXF/DWG形式で保存されます。
    • モデルスペース: レイアウト上に配置された全ての要素、全ての図面データがAutoCADの図面のモデル空間に保存されます。全てのレイアウトの図面はAutoCADブロックに変換され、ArchiCADのレイアウト上で表示できる一部のみがクリップされAutoCADモデル空間で表示されます。このオプションは、レイアウトに表示した内容を完全に再現するために使用します。このオプションを使用すると、デフォルトのペーパースペースは、生成されるAutoCADの図面に完全に空白の状態で作成されます。更新された内部図面はAutoCAD内の同じレイヤーにレイヤー名変換によって配置されます。内部図面の要素は更新されず(例.手動更新の図面)にAutoCADレイヤーに別々に配置されます。レイヤー名は図面名とIDの組み合わせになります。外部図面の要素は”図面と画像”というAutoCADのデフォルトレイヤーに配置されます。
  • 図面の配置先: この設定はペーパースペース ビュー一部もしくはペーパースペース ビュー全体オプションで有効になり、配置した図面をどう保存するか選択できます:

    • 単一DXF/DWGファイル: 全ての図面が単一のDXF/DWGファイルtに保存され、ファイルのモデル空間に並んで配置されます。ArchiCADのレイアウトのように、ビューポートがペーパー空間に作成されます。
    • リンクされたXREF図面: 全ての図面が個別のDXF/DWGファイルに保存されます。図面は最初のDWGにXREFとしてモデル空間に並んで配置され、ArchiCADのレイアウトのように、ビューポートがペーパー空間に作成されます。参照図面のフォルダパスはAutoCAD図面をエクスポートされた配置場所に関連して決められます。

注意: DXFファイル形式のXREFの制御は制限があり、XREFの設定の使用はAutoCADに手動で関連付ける必要があります。

  • 平面図の保存:

    • 複雑な要素をブロックに変換: 複雑な要素はAutoCADのブロックとしてエクスポートされ、ArchiCAD要素を分解する必要がない場合に使用します。
    • 複雑なArchiCAD要素を単純な要素要素に分解: ArchiCADからDXFファイルにエクスポートするときにこのオプションを使用すると、ブロックを作成しません。
    • オブジェクトをブロックに変換: このオプションでは、GDL要素をブロックに変換します。他の全ての要素は図面要素に変換されます。
    • 特殊結合のためにファイルを準備: 協力会社と協業するとき、DXF/DWGファイル用に特別なデータが必要になるかもしれません。スマート結合を使用するには、最初にプロジェクトを保存します;このオプションはプロジェクトがまだ保存されていない場合、非表示になります。
  • ゾーンを保存:

    • スタンプのみ: ゾーンスタンプは背景の塗りつぶしなしでエクスポートされます。
    • スタンプと塗りつぶし: ゾーンスタンプとゾーン塗りつぶしが、表示されている状態のモデル表示オプションで保存されます。
  • 3Dデータの保存: 注意: 3Dデータオプションは3Dウィンドウで保存時にのみ表示されます。

    • ポリゴンエッジを省略: ArchiCADの3Dウィンドウのポリゴンエッジのカラーは表面の色でたいてい異なります。チェックボックスを外す事とAutoCADと同様の動作を意味します。チェックを付けた場合、エッジのラインはエクスポートされません。
    • シンプルなデータ構造のファイルをエクスポート: このオプションは”複雑なArchiCAD要素を分解”オプションんと似ています-全てのデータがブロックではなく、エンティティとなります。

属性

DXF/DWGファイルの属性(5つグループに分類:レイヤー、ペンとカラー、線種、塗りつぶし、フォント/スタイル変換)は個別の設定でエクスポートできます:

レイヤー

手法

  • AttrLayMetCrLayAcc.png

  • レイヤーの作成条件:

    • ArchiCADレイヤー: ArchiCADのファイルのレイヤー構成でDWGが作成されます。
      • ペン番号: ペン番号を含むカスタム名でレイヤーを作成し、要素は使用しているペンを基にしたレイヤーに配置されます。レイヤー名はペン基準のレイヤー名テーブルで作成されます。
      • 要素タイプ: レイヤーは配置された要素タイプに応じて作成されます、例えば、”屋根”、”スラブ”、”ポリライン”、”ドア”、”窓”などです。
      • レイヤーあるいは既定ペン番号: ペン基準のレイヤー名テーブルの入力からレイヤーを作成します。残りの要素は既存のArchiCADレイヤーを基に作成されます。
      • ペン番号で拡張されたレイヤー: 2つの部分からカスタムレイヤーが作成されます、既存のレイヤー名とペンの両方から、ペン基準のレイヤー名テーブルで作成されます。
  • 要素を保存:

    • 全てのレイヤー:表示、非表示レイヤーにかかわらず全ての要素がエクスポートされます。
    • 表示レイヤーのみ:非表示レイヤーの要素は除外されます。
  • カスタムレイヤーを作成: これらのフィールドで窓、ドアおよびドアマーカー、天窓、作図塗りつぶし、表面塗りつぶし、切断塗りつぶし、壁の仕上げ分離線やゾーンに関連する項目を別個のレイヤーに設定でき、それらの所属する構造要素のレイヤーと別途にします。例えば、窓は壁レイヤーでエクスポートされます。切断線(構造要素や複合構造の切断輪郭)や’作図線’とした線種などのカテゴリはそれぞれ元のレイヤーに設定されます。もし柱に仕上げがない場合、輪郭が’切断線’のカテゴリに属します。もし柱に仕上げがあり、輪郭は’切断線’カテゴリに属し、躯体と仕上げは’仕上げ分離線’カテゴリに属し、それに応じて保存されます。塗りつぶしが”切断塗りつぶし”カテゴリに設定された塗りつぶしの輪郭は’切断線’カテゴリに属します。他の塗りつぶしの輪郭は’作図線’カテゴリに属します。
    どのカスタムレイヤーもレイヤー名変換テーブルによって作成され、カスタムレイヤーが最終的にDWGレイヤーに変換されることに注意ください。

  • ソースレイヤーを挿入ボタンは既存のArchiCADモデルの要素のレイヤー名をカスタムレイヤー名に含む場合に使用します。<ソースレイヤー>がレイヤーフィールド配置され、エクスポート中に既存のレイヤー名に置換されます。

例:: 窓を含んだ壁は「壁-躯体」レイヤーに配置されています。もしの「窓_」と窓カスタムレイヤーに入力し、「ソースレイヤーを挿入」をクリックすると、窓のフィールドに「窓_<ソースレイヤー>」と表示されます。結果としてエクスポートされたDWGのレイヤー名は「窓_壁_躯体」となります。

ペンに基づくレイヤー名

これらのオプションはレイヤーの設定がペン番号、レイヤーあるいは規定ペン番号、ペン番号で拡張されたレイヤーのときのみ表示されます。

  • ペン番号にカスタムタグ: ペン番号に接頭文字、接尾文字を追加できます。

  • カスタムレイヤー名割り当て: この一覧で上部の接頭/接尾文字の入力をしない例外を作成できます。ArchiCADのペン番号を特定し、正確なDWGレイヤーが作成されるようにします。テンプレートファイルが保存オプションで特定されていると、レイヤーはドロップダウンメニューから選択できます。

レイヤー名変換

  • EditTheLayerConvItemBasedOnTempl.png

このテーブルでは特定のArchiCADレイヤーもしくは別のレイヤーの要素を指定したAutoCADレイヤーに配置します。テンプレートファイルが特定の保存オプションで特定されていると、ドロップダウンメニューから指定して特定のDWGに指定できます。

注意: “外壁”、”内壁”の両方をAutoCADの”壁”に変換するときに問題がおきるかもしれません。変換する壁レイヤーがArchiCADに戻るとき、2種のArchiCADの壁のレイヤーを区別することができません。

ペンとカラー

AutoCADのペン番号と色の関連付けを変更しない限りはArchiCADのペンカラーは設定可能です。 ArchiCADのペンをAutoCADカラーに検索によって最も良い色を合わせる、もしくは変換辞書を作成します。

手法

手法ではArchiCADのペンをAutoCADのカラーに合わせます

  • PensMethods.png

  • ArchiCADペンをAutoCADカラーに変換:
    • 最適なAutoCAD標準カラーを使用。すべてのArchiCADのペンが最も近い色(RGB)のAutoCADカラーにマッピングされます。
    • 一致するAutoCAD標準カラーがない場合RGBカラーを使用。ArchiCADペンの設定が他にされているとAutoCADで設定されたペンは変更されません。AutoCAD2004以降ではRGB値でペンカラーを指定できます。このペンはペン番号が256以上になります。正確なRGBカラーが見つからない場合はRGBの値でエクスポート、ペン番号は256番以降になります。このオプションはDWG2000もしくは2002形式ではエクスポート時には表示されません。
  • すべての要素のカラーと太さを”BYLAYER”に設定:このオプションはArchiCADのペンからAutoCADカラーへの変換オプションを上書き、すべての要素のカラーはBYLAYERに設定されます。AutoCADユーザーがレイヤーにアタッチされたカラーを変更すると、そのレイヤーのすべての要素がすぐにその色に変更されます。
  • ArchiCADのペン太さをエクスポートしない:出力時に線種太さを0.00mmでエクスポートします。

ペン/カラー変換

  • DWGExportPenColours.png

ペン/カラー変換の変換辞書内のカラーの組み合わせはペンの手法の自動変換よりも優先されます。DWGを変換するとき、変換テーブルに指定したペンを除いて、ArchiCADペンはAutoCADカラーの最も近い色(RGB)の構成にマッピングされます。

このテーブルはArchiCADのペンとAutoCADカラーのペアです。ペンのID番号でエクスポートされる場合はこのテーブルにしたがって変換されます。この変換は変換する手法よりも優先されます。ペンの太さはDWGエクスポート中は使用されません。

線種

線の太さはAutoCADがそれぞれの要素に固有の線の太さを持たせるのとは反対にArchiCAD内のペン属性に割り当てられます。ファイルを保存する際、変換テーブルの線種を設定するかArchiCADの全ての線種AutoCADのBYLAYERで1種類にするかを設定できます。シンボル線種はArchiCADとAutoCADで格納することは難しい事にご注意ください。これらの違いはいくつかのArchiCADのシンボルの線種がAutoCADのそれとは同じように見えなくなります。

手法

  • DWGExportLineMethods.png

  • 全ての要素の線種を”BYLAYER”に設定: このオプションにチェックを入れると、保存された要素の全ての線種がBYLAYERに設定されます。AutoCADユーザーがレイヤーにアタッチされた線種を変更すると、レイヤー内の全てがその線種に直ちに変更されます。

線種の変換での辞書の効果が上書きされるので注意してください。

  • 出力ファイルの線種スケール値: 線種スケールはAutoCADの印刷する際の図面のスケールに応じて関係します。エクスポートするDWGの線種スケールのデフォルト値を入力します。

線種変換

  • LineTypeConversion.png

シンボル線種はArchiCADとAutoCADでは異なって格納され、ArchiCADのいくつかのシンボル線種はAutoCADと同じようには見えません。この問題には2つの対策があります:

  • 異なる箇所がなくなるまで問題の線種の設定を修正します。
  • それを許容できる置換を含んだテンプレートファイルを設定します。

エクスポートされたDWGのカスタム線種で作成されるほとんどの情報は、DWGのカスタム線種のエクスポートの記事をご覧ください。最も簡単方法はArchiCADで異なる線の太さを設定し、線の太さをレイヤーもしくはカラーに割り当てることです。

AutoCADでの手順を単純にする場合:

  • オブジェクトがレイヤーごとに個別の線の太さが必要ならば、[変換設定]>[属性]>[ペンとカラー]>[手法]タブの全ての要素カラーをBYLAYERに設定にチェックボックスを入れます。AutoCADでファイルを開いたときに、線の太さはレイヤー設定のダイアログで使用して設定します。

  • 線の太さをカラーで割り当てたい場合、ArchiCADカラーを使用してDWGを保存します。AutoCADでDWGを開くとき、カラー別の要素を選択でき、オブジェクトの線の太さや、印刷/プロットで使用するパラメータを含んだ出力スタイルのテーブルを作成できます。ここでカラー別のペンの太さを割り当てます。

塗りつぶし

ArchiCADの塗りつぶしはソリッド塗りつぶしとして保存することができます。また、背景塗りつぶしを追加ポリゴンとしてエクスポートできます。(この機能はAutoCADにはサポートされていません)。

手法

  • DWGExportFillMethods.png

– 全ての塗りつぶしを”SOLID”として出力: 全ての塗りつぶしはソリッド塗りつぶしとしてエクスポートされます。この場合DWGは2つの塗りつぶしの重複を含みます、(背景からの)ソリッドと(前景からの)パターンです。空の塗りつぶしはソリッド塗りつぶしとしてエクスポートされますが、透過は除きます、この場合それらは境界ポリラインになります。

– シンボル塗りつぶしを”SOLID”として出力: 全てのシンボル塗りつぶしがソリッド塗りつぶしとして出力されます。この場合DWGは前景のソリッド塗りつぶしのみを含み(パターンはソリッドに変換されます)、背景情報は失います。空の塗りつぶしはソリッド塗りつぶしとしてエクスポートされますが、透過は除きます、それらは境界ポリラインになります。

– 全ての塗りつぶしをそのまま”出力”: ArchiCADの塗りつぶしをAutoCADで再度作成し、同じ表示にします。

  • 塗りつぶし背景を追加のソリッドハッチとして出力: ArchiCADの塗りつぶしパターンは背景塗りつぶしと分割されます、AutoCADの塗りつぶしは線のパターンの間が透過になります。このオプションでは背景用に別の塗りつぶしを作成してDWGでの表現を同じにします。このオプションは塗りつぶしを”ソリッド”として出力だと非表示になります。
  • グラデーション塗りつぶしに分解: グラデーション塗りつぶしを別のコンポーネントに分解します。背景を透過としたグラデーション塗りつぶしも分解されます。
  • 塗りつぶし変換テーブルを使: 次の変換テーブルの変換に使用します。

塗りつぶし/ハッチ変換

ArchiCAD 12よりDWGトランスレータはArchiCAD塗りつぶしを特定のAutoCADハッチ種類に変換することができます。新しくテーブルの行を作成するには”新規”のボタンをクリックします。

  • DWGExportFillTable.png

保存オプションで特定するテンプレートファイルに必要なのは、テンプレートファイルに少なくとも1つは望むハッチのインスタンスが配置されていることです。ArchiCADの塗りつぶし種類はドロップダウンメニューから選択でき、テンプレート内で使用されているハッチがドロップダウンメニューに表示され、選択できます。

線および塗りつぶしの整理

フォント/スタイル変換

ArchiCADプロジェクトをDXF/DWGに保存するとき、結果とsいてテキストはArchiCADでの見え方と異なる可能性があります。たとえば、テキスト間のスペースが異なり、それによりテキストブロックが同じ長さやサイズにならないかもしれません。さらには、フォント名がDXF/DWGとArchiCADで異なって格納される可能性もあります。1つ1つフォントをマッチングすることも可能ですが、辞書が必要です。(Windowsでは、ArchiCADはインストールされたAutoCADに含まれる使用可能なフォントをサポートします)

  • FontConversion.png

DWGをエクスポートするとき、テキストフォントが辞書に一覧され、ArchiCADのスタイルからAutoCADのスタイルに変換テーブルに応じてそれらは変換されます。 ArchiCADのフォントはドロップダウンメニューから選択できます。AutoCADのスタイルは保存オプションんで指定したテンプレートファイルの一覧がドロップダウンから選択できます。傾斜角度のオプションはフォントに角度の値を設定できます。 傾斜のパラメーターは15(15度)かそれ以上にすると、エクスポートされたテキストはイタリック体となります。一般的には、イタリック体は傾斜角度は75度です。

テンプレートファイルが選択されていない場合、スタイルは、ArchiCADのフォントのAutoCADの対応を使用します。(ArchiCADが動作するプラットフォームに依存しない、フォントの変換ファイルの特定が最も合います)


その他

これらのグループ設定はフォントの変換オプション、スプラインの変換、未使用の属性のパージの機会を含みます。

Miscellaneous.png

  • レイヤー、線種、ブロック名で多言語文字を使用可: エクスポートされたDWGを同じ国内の環境でローカルの文字を使用する場合はこの設定を使用します。チェックを外すとアクセント/発音符号や特殊文字を除外し、それらの文字はアンダースコアに置換されます。

  • バイナリDXFの書き出し: この圧縮されたDXFのバージョンはテキストDXF形式の半分程になります。しかしながら、このフォーマットはまだDWGにエクスポートするときほどコンパクトではありません。

  • スプラインをポリラインに変換: ArchiCADのスプラインをポリラインに変換するときにこのボックスにチェックを入れます。ArchiCADはAutoCADスプラインが使用する直線セグメントの接続(ポリライン)の近似を使用します。このボックスにチェックしない場合AutoCADのスプラインはArchiCADのスプラインに変換されます。

  • 使用していない属性をパージ: ArchiCADファイルをDWGとして保存するとき、ArchiCADの属性のみを使用してプロジェクトが出力されます。これは自動的に行われ、ファイルサイズが減少します。

テンプレートファイルに関しては保存オプションをご覧下さい、このオプションのチェックを外すとそれらを使用する市内にかかわらず、テンプレートファイルから全て属性がDWGプロジェクトの一部として保存されます。 このオプションはテンプレートファイルから使用しない属性をパージします。


カスタム機能

カスタム保存機能

カスタム機能は開く(カスタム開く機能)と保存(カスタム保存機能)の両方があります。いくつかの機能はデフォルトえ読み込まれています;必要に合わせてチェックボックスの有効化、無効化を行います。

AutoCADでエクスポートしたDWGファイルを開く際、警告メッセージが表示されます。DWGファイルを開くを継続するとプロジェクトを開くことができます。

Related content

DXF-DWGトランスレータの設定

DXF-DWGトランスレータの設定 DXF-DWGトランスレータは、設計プロセス全体に渡って設計担当者がその他のグループと簡単にコミュニケーションを行えるようにします。DXF-DWGトランスレータファイルを定義および開発するには、ArchiCADとAutoCADについての深い知識を必要とし、以下に挙げるさまざまな状況を十分に考慮して行う必要があります。 事務所内の既存のDXF-DWG標準(レイヤー、ペン、塗りつぶし、名前など)…

テンプレートファイル

テンプレートは、拡張子.tplが付いた読み取り専用のプロジェクトファイルです。テンプレートには全てのプロジェクト設定、配置された要素およびプロジェクトのツールのデフォルト設定が含まれます。 ArchiCAD には、デフォルトライブラリと一緒にデフォルトテンプレートファイルが同梱されています。インストール時に、デフォルトテンプレートはデフォルトフォルダ内に保存されます。 デフォルトフォルダの場所は以下のとおりです。 Windowsの場合は、C:\Program…