GDLオブジェクトエディタ

GDLオブジェクトエディタには、GDLオブジェクトの編集に必要な全てのコントロールが含まれています。

スクリプト作成コマンドとオブジェクトレベルの編集については、ARCHICADヘルプメニューで提供される『GDLリファレンスマニュアル』を参照してください。

GDLオブジェクトエディタを開く

以下のいずれかの方法で、GDLオブジェクトエディタを開きます。

配置されたオブジェクトの場合:オブジェクトを選択し、[ファイル]→[ライブラリとオブジェクト]→[オブジェクトを開く]を使用します(または[GDLライブラリ部品を編集]ツールバーからこのショートカットコマンドを選択します)。

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/OpenObject.png 

任意のオブジェクトファイルの場合(そして配置されたオブジェクトを選択していない場合):[ファイル]→[ライブラリとオブジェクト]→[オブジェクトを開く]を使用して、目的のオブジェクトを参照します。

サブタイプ別のオブジェクト参照方法:[GDLライブラリ部品を編集]ツールバーから[サブタイプ別にオブジェクトを開く]コマンドを使用します。

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/EditGDLToolbar001.png 

GDLオブジェクトエディタのウィンドウが開きます。

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/GDLMasterWindow.png 

左側のボタンをクリックすると、GDLオブジェクトエディタ内に別のテーブル/リストが開いて(詳細、パラメータ、構成要素などを)編集できるようになります。

スクリプト編集ウィンドウ(特性スクリプト、パラメータスクリプトなど)は、2通りの方法で開くことができます。

ボタン自体をクリックすると、編集はマスタウィンドウ内で行われます。

スクリプト名の横のウィンドウアイコンをクリックすると、個別のウィンドウが開いてスクリプトを入力または修正できます。

これらの個別のウィンドウから、そのタブバーのコンテキストメニューを使用して、簡単にマスタウィンドウに戻ることができます。

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/TabContext2.png 

ライブラリコンテナファイル内の「読み取り専用」オブジェクト

ライブラリコンテナファイルに配置されているオブジェクトを編集するには、まずコンテナを展開する必要があります。そうしないと、オブジェクトエディタウィンドウは「読み取り専用」になります。

詳細は、「ライブラリコンテナファイル」を参照してください。

このセクションのトピック

GDLオブジェクトエディタの内容については、下記セクションで説明します。

オブジェクトのプレビュー画像

詳細図

互換性オプション(開発者専用)

パラメータ

移行

構成要素

記述項目

スクリプトボタン

GDLスクリプトウィンドウショートカット

2Dシンボル

2Dシンボル表示(断片)

プレビュー画像

オブジェクトの2Dおよび3Dビューを確認

ウィンドウを閉じて変更内容を保存

2D記述と3D記述の一致

オブジェクトのプレビュー画像

[プレビュー画像]ウィンドウは、5つの形式のいずれか1つで表示できます。

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/ObjectPreview.png 

ウィンドウの横のボタンの1つをクリックして、プレビュー画像の表示オプション(2Dシンボル、2Dビュー、正面、3D、プレビュー画像)を選択します。

[正面]または[3D]プレビューでは、プレビューウィンドウ内をクリックして、画像を45度ずつ回転できます。

詳細図

[オブジェクトのサブタイプ]:開かれたオブジェクトのサブタイプを表示します。

オブジェクトのサブタイプを変更するには、[サブタイプを選択]ボタンをクリックして、前述の[サブタイプ階層]ダイアログボックスを開きます。オブジェクトのサブタイプを変更するとオブジェクトの特性が修正され、新規サブタイプに必要なパラメータと機能が追加されます。例えば、サブタイプを[Light]に変更すれば、オブジェクトを光源に変更できます。

詳細は、「[サブタイプ階層]ダイアログボックス(GDLマスタウィンドウ)」を参照してください。

[サブタイプとして使用]:このボックスをチェックすると、オブジェクトはテンプレートとして保存され、使用可能なサブタイプリストに追加されます。新規テンプレートが[サブタイプ階層]ダイアログボックスに表示され、このサブタイプに関連付けた新規オブジェクトは、このサブタイプの全てのパラメータを継承します。

[配置可能]チェックボックスは、デフォルト時、有効です。それをチェック解除すると、オブジェクトはマクロとして機能します。このボックスをチェック解除すると、以下の結果を生じます。

オブジェクトがツール設定ダイアログボックスに表示されない。

オブジェクトを直接にプロジェクトに配置できない。

オブジェクトをアーカイブ保存されたプロジェクトファイルに追加できないが、

他のオブジェクトからそのスクリプトを参照することはできる。

オブジェクト情報フィールド

次のいくつかのコントロールは、ライブラリ部品をBIMコンポーネントで共有する場合、または独自のオブジェクトを商用にする予定がある場合に使用されます。また、ライブラリ部品の設定ダイアログボックスで検索機能を使用してライブラリ部品を見つける場合には、ここで入力したテキストが使用されます。

ライブラリ部品の検索」を参照してください。

必要に応じて、以下の情報を編集します。

作成者を入力します(これを空白のままにした場合は、オブジェクトを共有すると、BIMコンポーネントの登録に使用した名前が作成者として使用されます)。

著作権を割り当てます。ここでは次の3つのオプションがあります。

[パブリック・ドメイン・デディケーション]。[情報]ボタンをクリックすると、詳細を記載した次のWebページに移動します:
https://creativecommons.org/publicdomain/zero/1.0/deed.ja

[表示 – 改変禁止]。[情報]ボタンをクリックすると、詳細を記載した次のWebページに移動します:http://creativecommons.org/licenses/by-nd/3.0/deed.ja

[商用版]。この著作権は、オブジェクトをインターネット上で販売する場合に使用します。商用版のオブジェクトは、BIMコンポーネントで共有できません。[情報]ボタンをクリックすると、詳細を記載するWebページに移動します。

パスワード(著作権が「表示 – 改変禁止」または「商用版」の場合に使用可能)。[パスワードを設定]をクリックして、任意のパスワードを定義します。このようなオブジェクトは自由に表示およびダウンロードできますが、パスワードがなければ、オブジェクトを開いてスクリプトを編集およびコピーすることはできません。

[説明] オブジェクトに対する任意の説明を入力します。このテキストは、設定ダイアログボックスで[情報]ボタンをクリックしたとき、およびオブジェクトがBIMコンポーネントで共有されている場合はそこで表示されます。また、ライブラリ部品の設定ダイアログボックスで検索機能を使用してライブラリ部品を見つける場合には、この説明テキストが使用されます。

互換性オプション(開発者専用)

詳細情報については、GDLセンターにお問い合わせください。

gdl.graphisoft.comを参照してください。

パラメータ

[パラメータ]ボタンをクリックすると、編集領域に現在のライブラリ部品のパラメータが表示されます。

[検索パラメータ]:検索フィールドにテキスト文字列を入力すると、変数、名前、または値列でその文字列の一部が検索されます。最初に見つかったインスタンスにカーソルが移動します。[後方検索]/[前方検索]ボタンをクリックすると、次に検索されたインスタンスに移動します。

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/SearchObjectParameters.png 

パラメータリストの変数セットに値を割り当てることによって、特定のGDLオブジェクトの属性を定義します。ここで割り当てた値は、GDLオブジェクトを使用するツールを選択した時に、設定ダイアログボックスに表示されるデフォルト値になります。ローカルに定義したパラメータをオブジェクトの各種スクリプトでも呼び出せます。

青色のパラメータは、編集対象オブジェクトのサブタイプに属する必須パラメータです(AおよびBの寸法など)。

オブジェクトのGDL記述に使用するオプションパラメータを設定できます。このパラメータに指定した値は、ツールボックスから適切な設定ダイアログボックスを開いた時に表示されるデフォルトの追加パラメータ値になります。

オプションパラメータは、窓ガラスやドアパネルの数、部品の一般的な材質などを定義するために通常使用されます。

マスタウィンドウ上部の[新規]ボタンを押すと、新規パラメータを作成できます。既存のパラメータを削除するには、削除するパラメータをリストから選び、[新規]ボタンの隣にある[削除]を押します。

リスト内の各パラメータは、そのパラメータが配置されている行の中で編集できます。各行は、アイコン(必須)、パラメータのタイプ、パラメータを表す文字または文字列の変数、記述テキスト(オプションですが、設定を推奨)、およびデフォルト数値で構成されます。

編集する行を選択して強調表示にします。必須パラメータの場合、変数名または変数タイプのアイコンは編集できません。オプションパラメータの場合、全てのパラメータを編集できます。

タイプアイコンは、ARCHICADによる値の解釈を制御します。タイプアイコンをクリックすると、別のアイコンを選択してパラメータのタイプを再定義できるダイアログボックスが表示されます。

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/Integer.png 

パラメータのタイプ(必須パラメータとオプションパラメータに共通) は次のとおりです。

[長さ]:

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/Length.png 

GDLオブジェクトの物理的寸法を指定します(さらに使用する単位への変換を行います)。正の数字でなければなりません。

[角度]:

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/Angle.png 

回転変換や円弧の定義などのGDL操作に使用する度(小数)単位で、角度値を指定します。

[実数]:

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/RealNumber.png 

GDL計算に倍率を含めるときなどに使用するような、寸法(実数)ではない小数値を指定します。

[整数]:

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/Integerpici.png 

GDL記述における同一構成要素の数やGDLスクリプトの一部をループさせる回数の定義などに使用するような、寸法ではない整数の値を指定します。

[ブール]:

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/Booleanpici.png 

ブールパラメータの値は1か0のいずれかで、GDLオブジェクト内の動作や項目を有効または無効にするような場合に使用します。この値は、値ボックスに直接入力するか、パラメータ行の右端にあるチェックボックスをクリックして設定します。

[テキスト]:

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/abc.png 

GDLオブジェクトの変更を定義したり、パラメータの値ボックスに数値ではなく単純な語句を入力したりするときなどに使用する、最大255文字の文字列を指定します。

[材質]:

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/Materialpici.png 

GDLパラメータとしての材質を指定します。

[線種]:

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/Linepici.png 

GDLパラメータとしての線種を指定します。

[塗りつぶし種類]:

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/Fillpici.png 

GDLパラメータとしての塗りつぶしパターンを指定します。

[ペン]:

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/Penpici.png 

GDLパラメータとしてのペンカラーを指定します。

注記:材質、線種、塗りつぶしパターン、またはペンカラータイプのパラメータを選択した場合、パラメータ行の右端にボタンが表示されます。このボタンをクリックすると、対応する設定のポップアップリストが表示されます。現在ARCHICADで使用可能な属性のいずれかを選択できます。

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/107_12.png 

注記:GDL記述の書き方によっては、使用するパラメータをライブラリ部品の2Dと3Dの両方の表示に影響を与えられます。

パラメータのタイプには、さらに[分離記号]と[タイトル]という2つのオプションがあります。

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/Separatorpici.png     //helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/Titlepici.png

これらは非表示パラメータであり、パラメータリストを整理して見やすくするためだけに使用します。

パラメータリストをさらに整理して形式を設定するには、リスト項目が強調表示されている時にのみ表示されるリスト形式アイコンのいずれかを使用します。

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/lib_main_para_form.png 

最初のアイコン([パラメータを隠す])を押すと、強調表示されているパラメータがオブジェクト設定ダイアログボックスの[パラメータ]パネルから削除されます。

2番目のアイコン(従属)を使用すると、パラメータの階層を作成できます。あるパラメータを別のパラメータの下に配置した場合、この従属パラメータはオブジェクト設定ダイアログオブジェクトのパラメータリストの中のサブリストに表示されます。サブリストを開閉するには、上の階層のパラメータの隣にある小さな三角形を押します。上の階層のパラメータはどのタイプのパラメータでもかまいませんが、タイトルタイプのパラメータを従属パラメータにはできません。

3番目のアイコン(太字)を押すと、パラメータ名が太字で表示されます。

4番目のアイコン(ユニーク)を押すと(有効な場合)、このオブジェクトのその他のパラメータを他のオブジェクトに転送しても、現在のパラメータは転送されません

オブジェクト間のパラメータの移動」を参照してください。

配列を定義することによって、パラメータの可能な値を制限できます。

パラメータリストのリスト項目を強調表示すると、タイプアイコンの隣に新しいボタンが表示されます。

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/lib_main_para_array.png 

ボタンをクリックして、単一の値または値リストと配列を切り替えます。配列に切り替えられている場合、ボタンをクリックすると、[配列値]ダイアログボックスが開きます。

注記:パラメータの配列値を定義した後は、マスタウィンドウ上部の[設定]ボタンを押した時にのみ[配列値]ダイアログボックスが開きます。

[挿入]および[削除]ボタンをクリックすると、行または列が追加されます。配列のフィールドを編集するには、フィールドをクリックした後、右側の数値フィールドに値を入力します。変数のタイプによっては、ポップアップメニューから値を選択できます。

行、列の挿入、削除を行うには、行/列番号を表示したボタンを選択した後、[挿入]または[削除]を押します。

移行

[移行]ボタンをクリックすると、現在開いている(より新しいバージョンの)オブジェクトに移行する必要のある古いバージョンのオブジェクトを定義するテーブルが開きます。

現在開いているこの新しいオブジェクトに移行できる古いオブジェクトのメインのGUIDを入力します。

古いオブジェクトのバージョン番号(通常はARCHICADの前バージョン)を入力します。プロジェクトを前のバージョンで保存する場合(そして[名前を付けて保存]ダイアログボックスのオプションで[ライブラリオブジェクトを下位変換]を設定した場合)、この新規オブジェクトは移行テーブル内の対応するバージョン番号が割り当てられている古いオブジェクトに移行されます。下位移行スクリプトは、最初の実行が成功するまで、このような全ての行を考慮します。

注記:バージョン番号に0を入力すると、下位移行はこのオブジェクトをスキップします。

構成要素

このボタンをクリックすると、編集領域に現在のGDLオブジェクトの構成要素が表示されます。構成要素は、リストおよび計算機能で使用するオブジェクトの構成を示します。

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/GDLComponent.png 

構成要素を作成するには、[新規]をクリックします。

[DBセット]:このポップアップメニューから、データベースを選択します。

[キー]:ポップアップメニューで、レンダリングエンジンを1つ選択します。

注記:このポップアップメニューは、ロードしたライブラリがキー記述を含む場合のみ使用できます。

[コード]:このボックスでは、新規の構成要素のコードを設定するか、選択した構成要素のコードを変更します。

[数量]:新規の構成要素の数量を設定するか、選択した構成要素の数量を変更します。

[単位]:このポップアップメニューから定義済みのGDLスクリプトを1つ選択します。

注記:このポップアップメニューは、ロードしたライブラリが単位記述を含む場合だけ使用できます。

[これと比例する]:このポップアップメニューから定義済みのGDLスクリプトを選択するか、カスタムボタンを選択して上の長い編集ボックスにGDLスクリプトを入力します。

構成要素編集の詳細は、『ARCHICAD計算ガイド』を参照してください。

記述項目

このボタンをクリックすると、編集領域に現在のGDLオブジェクトの記述項目が表示されます。記述項目は、リスティングおよび計算機能で使用するオブジェクトの構成を示します。

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/Descriptor.png 

記述項目を作成するには、[新規]をクリックします。

[データベース項目へリンク]:このボタンをクリックすると、構成要素または記述項目が、ロードしたライブラリの選択したデータベースに存在する外部データベースにリンクされます。選択したデータベースへリンクされた構成要素または記述項目は、編集できません。それを修正する場合は、[データベースへのリンクを解除]ボタンをクリックして、構成要素または記述項目のリンクを解除します。

[リンクの変更]:これをクリックすると、別の外部データベースに対する既存のリンクを再定義できます。

[テキスト]:[記述項目フルテキスト]ダイアログボックスが開き、記述項目の全テキストが表示されます。

[ショートテキスト]:新しい記述項目のショートテキストをこのボックスに入力します。

記述項目編集の詳細は、『ARCHICAD計算ガイド』を参照してください。

スクリプトボタン

以下のボタンを使用して、GDLオブジェクトのプログラミングを実行できます。ボタンそのものをクリックした場合は、マスタウィンドウで編集が行われますが、スクリプト名の隣にあるウィンドウアイコンをクリックすると、スクリプトの入力または修正用のウィンドウが別に開きます。

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/ScriptWindows.png 

[マスタスクリプト]は、他のいずれかのスクリプトが実行されるたびに実行されます。このスクリプトの主なメリットは、変数または操作を全体的に定義したり、他のスクリプトの実行前に外部データにアクセスすることができる点です。

[2Dスクリプト]ウィンドウでは、GDLの2次元領域で利用可能な変換と要素を使用して、パラメトリックな2Dシンボルを作成できます。このスクリプトは、オブジェクトの2D全体表示を生成するために使用されます。

[3Dスクリプト]ウィンドウでは、GDLオブジェクトの3D記述の検索と編集を実行できます。このスクリプトは、オブジェクトの3D表示を生成するために使用されます。

[特性スクリプト]では、変数、関連GDLコマンドおよび数式を使用して、記述および技術データをオブジェクトに付加できます。構成要素の数量(重量、価格、塗料など)は、特性スクリプトの式に基づいて計算し、リストに含められます。要素の設定ダイアログボックスでカスタム特性スクリプトをデフォルトとして使用するには、画面の上部の[デフォルトとして設定]ボタンをクリックします。

注記:定義済みの特性スクリプトが存在する時には、それ以前にダイアログボックスの対応するセクションで構成要素と記述項目を作成している場合でも、このスクリプトがリストコマンドで使用されます。

[パラメータスクリプト]を使用して、特定のパラメータの値として使用可能な選択肢を定義できます。例えば、テーブルの天板の材質を木材の中から選択するように制限や、特定のドアのパネルの種類を名前で定義ができます。

[インターフェイススクリプト]を使用して、GDLオブジェクトのカスタムユーザーインターフェイス(追加パラメータのグラフィックな説明を含む)を定義できます。インターフェイススクリプトが存在する場合は、そのライブラリ部品の設定ダイアログボックスに[カスタム設定]パネルが表示されます。要素の設定ダイアログボックスでカスタムインターフェイススクリプトをデフォルトとして使用するには、画面の上部の[デフォルトとして設定]ボタンをクリックします。

上位/下位移行スクリプト:[上位移行]または[下位移行]ボタンをクリックして、古いインスタンスのパラメータを現在開いている要素に上位移行(または古い要素に下位移行)する方法を定義します。

GDLスクリプトウィンドウショートカット

スクリプトウィンドウの上部には、よく使われる機能を表すボタンがいくつかあります。

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/CheckScript.png 

最初のボタンをクリックすると、選択されている行がコメント(スクリプト内の実行されない行)に変換されます。コメントは、行の先頭の感嘆符によって識別されます。

注記:複数の行を選択できます。

2 番目のボタンでは、逆の処理が行われます。このボタンをクリックすると、選択されているコメントが実行可能な行に変換されます。

3番目または4番目のボタンをクリックすると、選択されている段落が左または右にタブで送られ、スクリプトウィンドウの形式が設定されます。

最後のボタンをクリックすると、現在のウィンドウのGDLスクリプトがチェックされます。

注記:スクリプトウィンドウで作業を行う時、この全ての機能は[編集]メニューのメニューコマンドとしても使用できます。さらに、他の特別なスクリプトウィンドウ編集コマンドがあります。

注記:特性、インターフェイス、およびパラメータのスクリプト編集ウィンドウには、カスタムスクリプトのプレビューを表示する[プレビュー]ボタンも含まれています。

2Dシンボル

マスタウィンドウで2Dシンボル項目をクリックすると、新しい編集ウィンドウが開きます。

プロジェクトに配置する各GDLオブジェクトは、平面図では2Dシンボルで表示されます。矢印、矩形選択、テキスト、塗りつぶし、線、円弧/円、スプライン、ホットスポットなどの標準的なARCHICADの選択ツールと2Dツールを使って、既存のシンボルの編集や新規のシンボルが作成できます。3Dウィンドウの要素をここに貼り付けることも可能です。

平面図に表示される最終的なシンボルは、このウィンドウの要素と2Dスクリプト(存在する場合)から作成されます。

2Dシンボル表示(断片)

2Dシンボルの断片を表示するには、2Dシンボルボタンを選択し、[オプション]→[属性設定]→[レイヤー設定]に移動します。表示されるリストウィンドウに2Dシンボルの断片が表示されます。これは、ライブラリ部品の平面図シンボルを構成するグラフィック要素の組織化に便利です。

オブジェクトの2Dシンボルのレイヤー表示を切り替えるには、2Dシンボルウィンドウを開き、Ctrl+Lをクリックします(レイヤー設定のショートカット)。特殊なレイヤー設定ウィンドウが開きます。これはこのウィンドウ(2Dシンボルウィンドウ)のみに反映されます。

断片をクリックして表示/非表示にするか、または[全てを表示]/[全てを隠す]ボタンを使用します。

注記:非表示になっている断片は、新規の図形要素の格納には使用できません。シンボルの編集に使用しているツールのダイアログボックスで非表示の断片を選んだ場合は、選択を変更するか、選択した断片を表示することを求める警告メッセージが表示されます。

断片は特にシンボルの一部を複製する時にも役立ちます。2Dシンボルウィンドウで各種図形ツールを使って画像を描画し、最終シンボル内のさまざまな回転位置や変換位置に画像を組み込むGDL 2Dスクリプトで、断片の番号によって画像を参照できます。

2Dシンボルウィンドウの編集時に描画を行う断片を設定するには、使用中のツールの設定ダイアログボックスで番号を選択します。

プレビュー画像

プレビュー画像ウィンドウでは、特性の画像情報をGDLオブジェクトに添付できます。画像は、オブジェクトの動作や表示には何も影響しません。このプレビューは、参照ウィンドウに一覧にされたライブラリオブジェクトの横に表示されるとともに、ツールの設定ダイアログボックスに、オブジェクトのデフォルト表示として表示されます。

新規オブジェクトのプレビューを生成するには、以下の操作を行います。

1.プロジェクトにオブジェクトを配置します。

2.オブジェクトを選択して3Dウィンドウを開き、この選択を確認します。

3.[表示]→[3D表示設定]→[3D投影の設定]に移動します。投影タイプを選択し、オブジェクトの一般的な特徴を示すビューアングルを設定します。[OK]をクリックします。

4.[ウィンドウサイズを設定](3D Windowタブまたはコンテキストメニューから)を開きます。ウィンドウの高さと幅を同じ値に設定し、ウィンドウが正方形になるようにします。

5.[ドキュメント]→[レンダリング]→[レンダリング設定]を選択します。歪みを起こすことなくプレビューに挿入できるピクセルサイズを定義し、オブジェクトの背景として中間色(例えば、天空と地面には白)を選択します。

6.オブジェクトを選択したままで、[ドキュメント]→[レンダリング]→[レンダリングを実行]を選択します。モデル画像が生成されます。

7.[編集]→[全てを選択]を選択した後、[編集]→[コピー]を選択します。

8.平面図に戻ります。オブジェクトを選択したままで、[ファイル]→[ライブラリとオブジェクト]→[オブジェクトを開く]を選択します。選択されているオブジェクトのマスタウィンドウが開きます。

9.[プレビュー画像]アイコンをクリックして対応するウィンドウを開き、[編集]→[貼り付け]を選択します。

10.GDLオブジェクトを保存します。

他データ(例えば、オブジェクトの実物の写真など)をクリップボードからも貼り付けできます。

オブジェクトの2Dおよび3Dビューを確認

左下にある2つのビューボタンにより、対応するGDLオブジェクトのビューを開くことができます。

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac22_help/130-userinterfacedialogboxes/2D3DView.png 

2Dビュー

2Dビューウィンドウでは、平面図に表示されるシンボルを確認できます。

定義済みの2Dスクリプトが存在する場合には、2Dシンボルウィンドウに図面要素が含まれていても、2Dビューはこのスクリプトに従って計算されます。ただし、2Dスクリプトは2Dシンボル断片を参照できます。

2D シンボル編集を終了するには、シンボル編集ウィンドウを閉じるか、マスタウィンドウまたは[ウィンドウ]メニューで、異なるウィンドウを選択します。

3D表示

このウィンドウでは、現在のパラメータ値を参照する3Dスクリプトから変換されたGDLオブジェクトの3Dビューを確認できます。ビューポイントおよび他の要素は、[表示]→[3D表示設定]→[3Dスタイル]ダイアログボックスまたは3Dナビゲーションパレットを使用してコントロールします。

ウィンドウを閉じて変更内容を保存

マスタウィンドウを閉じる時には、変更内容を保存するように求める警告メッセージが表示されます。この時、項目の全ての構成要素を保存できます。

ライブラリ項目のウィンドウから[保存]コマンドまたは[名前を付けて保存]コマンドを使用して、項目を保存することも可能です(3D表示からは、[名前を付けて保存]による画像の保存だけが可能です)。保存後、修正したGDLオブジェクトを表示するには、平面図または3Dウィンドウに対して[表示]→[更新]→[再構築]コマンドを選択します。

GDLオブジェクト(ライブラリ部品)のマスタウィンドウを閉じると、そのオブジェクトの他のウィンドウも全て閉じます。変更を加えた場合は、変更内容を保存するよう求めるメッセージが表示されます。

2D記述と3D記述の一致

2Dシンボルと3D記述は、GDLオブジェクト内で自動的に連動します。これら2つの構成要素の形状の不一致に対する保護機能は内蔵されていません。最も一般的な不一致のエラーは、原点に対する位置または向きが2Dシンボルと3D形状で異なる場合に起こります。

このような問題の発生を防止するには、以下の操作を行います。

1.GDLオブジェクトの3D表示を有効にします。

2.[表示]→[3D表示設定]→[3D投影の設定]→[平行投影]を選択し、角度を270°に設定します。

3.[編集]→[全てを選択]を選択した後、[編集]→[コピー]を選択します。GDLオブジェクトの2Dシンボルウィンドウを開いて、[編集]→[貼り付け]を選択します。その結果、オブジェクトの上面図がワイヤフレームまたは陰線としてシンボルウィンドウに配置されます。この上面図は2Dシンボルの寸法および位置と一致します。

4.シンボルが3D表示と一致することを確認した後、[元に戻す]を選択します。これで3Dの線が削除されます。

この操作により、自動で2Dシンボルも作成できます。これ以降は、他のホットスポット、線種などの追加だけが必要です。この操作は、以下の修正点を除いて、ドアおよび窓の場合も同じです。

[上面図]の代わりに[側面図]を選択します(角度は270度に維持します)。

ミラービューが配置されます。配置された線を選択し、壁の基準線の反対側にミラーします。

注記:ワイヤフレームビューを配置した場合、重複線は削除されます。陰線処理を使用すると正確なビューが得られますが、下線は非表示になります。

GDLでシンボルのパラメトリックな記述を作成することにより、GDLオブジェクトの2D平面図シンボルと3Dモデルの整合性も保証できます。