DWG/DXFファイルを開く

DXFおよびDWG形式のファイルをARCHICADで図面またはレイアウトとして開くことができます。[ファイル]→[開く]を選んだ後、ディレクトリダイアログボックスで必要なファイルを選択します。

外部図面の配置方法については、「外部アプリケーションから図面を配置する」を参照してください。

[図面の設定]ダイアログボックスで、図面のサイズ、図面単位、タイトル、枠のオプションをカスタマイズできます。[図面の設定]の[埋め込みレイヤー]コントロールは、ソースファイルがDWG、DXF、またはDWFの図面で使用でき、これによりソースレイヤーの可視性を調整できます。

図面の設定」を参照してください。

ARCHICAD と AutoCAD 間のデータ交換の変換ルールは、変換設定 (拡張XML) と呼ばれるファイルに保存できます。

デフォルト変換設定を使用するには、[開く]コマンドを選択するだけです。そうすると、選択したファイルがARCHICADに開きます。ARCHICADのデフォルト変換設定は、ほとんどの場合に変換によって正しい結果が得られるように設定されています。

同時に、AutoCADとARCHICADの間の違いから、変換で正しい結果を得るにはカスタム設定が必要な場合もあります。

ファイルを開く前に変換設定の切り替えまたは設定の調整を行うには、 [設定] を選択して [DXF/DWG変換設定]ダイアログボックスを開きます。

このダイアログボックスは、以下の方法でアクセスできます。

インポート/エクスポートファイル形式がDXF/DWGである場合、[保存]、[開く]、[結合]ディレクトリダイアログボックス、または[XRFFのアタッチ]ダイアログボックスの[設定]ボタンをクリックして、データ転送操作を開始します。

[ファイル]→[相互運用性]→[DXF-DWG][DXF-DWG 変換設定]コマンドを使用して直接アクセスします。

[ファイル]→[ライブラリとオブジェクト]→[オブジェクトを開く]コマンドを使用してDXF/DWGファイルを開く。

[ファイル]→[ライブラリとオブジェクト]→[DXF/DWGからブロックをインポート]コマンドを使用する。

変換設定の管理は、[変換設定]ダイアログが開かれるたびに行うことができます。これは、データ交換(開くおよび保存)中であっても、変換の設定中であっても行えます。

チームワークユーザーへの注記:共通の変換設定を使うことで、全てのユーザーが確実に同じ変換オプションを利用できます。そのため、CADマネージャ(または事務所内で同じような役割を果たす人)が変換設定のセットを管理してサーバーに置くことをお勧めします。このような変換設定を使用するには、各ユーザーがまず各自の変換設定リストに変換設定を導入する必要があります。

変換設定の設定についての詳細は、「DXF-DWG変換設定」を参照してください。

ライブラリ部品として開く

[ファイル]→[ライブラリとオブジェクト]→[オブジェクトを開く]コマンドを選ぶと、 DXF/DWG ファイルをライブラリ部品として開くこともできます。 GDL マスタウィンドウが開き、ファイル全体から取得した新しいオブジェクトを設定できるようになります。

詳細は、「GDLオブジェクトエディタ」を参照してください。

ドラッグ&ドロップで開く

ドラッグ&ドロップでDXF/DWG図面をインポートできます。

CAD図面を左クリックして、目的の場所までドラッグ&ドロップします。最後に使われたDXF/DWG変換設定を使用してファイルが開きます。この方法では、DWG/DXFファイルはARCHICADプロジェクトファイルに結合されるだけです。ファイルの2Dの外観がインポートされるだけで、3Dコンテンツはインポートされません。

複数のDXF/DWGファイルをドラッグ&ドロップした場合、その中の1つのファイルだけがドロップされます。どのファイルをドロップするかは制御できないので、一度にドラッグ&ドロップするのは1つのファイルだけにすることをお勧めします。

AutoCAD図面を開いている/結合している間は、以下のようにドラッグ&ドロップ操作を使用できます。

ARCHICADアプリケーションウィンドウの背景、ARCHICADメニューバー、またはARCHICADアイコンにDXF/DWGファイルをドラッグ&ドロップすると、ファイルが開きます。

ARCHICAD の平面図、断面/立面/展開図、および 3D ドキュメントウィンドウ、または詳細図/ワークシートウィンドウに DXF/DWG ファイルをドラッグ&ドロップすると、ファイルが図面として配置されます。

DXF/DWG ファイルをレイアウトにドラッグ&ドロップすると、図面がレイアウトに配置されます。

パスワードで保護されたファイルを開く

AutoCAD 2004以降のバージョンでは、図面をパスワードで保護することができます。

AutoCAD 2004以降のバージョンのファイルをインポートするか、開くと、パスワードで保護されていることがあります。

現在、Macプラットフォームでは、AutoCAD 2004以降のパスワード保護されたDXF/DWGファイルを開くことはできません。これは、このパスワードメカニズムで使用される暗号化手法をOSがサポートしていないからです。そのような場合、Macに警告が表示されます。

Windowsでは、OSがパスワード復号化ルーチンをサポートしていない場合があります。この場合は、ファイルを開くことができないという警告が表示されます。

システムが復号化ルーチンをサポートしている場合、ダイアログが表示され、ファイルの送信者から受け取ったパスワードを入力できます。

XREFファイルの場合、XREFをARCHICADに最初に再ロードするときにプログラムからパスワードが求められます。複数の XREF ファイルを再ロードしている場合、パスワードで保護されたファイルのパスワードを間違って入力すると、そのファイルだけが再ロードされなくなります。

ブロックをライブラリ部品として開く

AutoCADのブロックに最も似ているのは、ARCHICADのライブラリ部品です。ブロック参照(図形の挿入)は、ライブラリ部品の要素と類似しています。違いは、ライブラリ部品は個別のファイルですが、ブロックはAutoCADファイル自体の中に保存されるという点です。

ブロックをライブラリ部品に変換することは、ブロックの3D構造を保持する唯一の方法です。ただし、比較的複雑なブロックを分解することの方がより効率的(格納スペースが少なくて済む)な場合もあります(例えば、 100本の線分を含むブロックの100の要素を分解すると、10,000本の線分になります)。

ブロックをライブラリ部品に変換することの欠点は、次のとおりです:

DXF/DWGのインポート中に作成されたオブジェクトライブラリ全体を定期的に整理して、重複している項目や不必要な項目を削除しなければならない。

ブロックに格納されている詳細に対して利用できる編集機能の一部は、ライブラリ部品の要素には利用できない。

DWG/DXF/DWFファイルの選択したレイヤーをインポート

開くオプション(DXF-DWG変換設定)」の[部分オープンを有効]を参照してください。

インポートするDWG/DXF/DWFファイルのレイヤーの表示/非表示

インポートするDWG、DXF、DWFファイルの表示を制御するには、[図面の設定]の[プロパティ]パネルにある[埋め込みレイヤー]コントロールを使用して、独自のレイヤー(ソースファイルのレイヤー)の表示/非表示を切り替えます。

//helpcenter.graphisoft.co.jp/wp-content/uploads/ac21_solo/07-interoperability/DrawingsOwnLayers.png 

このコントロールは、選択した図面のソースがDWG、DXF、またはDWFファイルの場合に使用できます。

詳細は、「埋め込みレイヤー」を参照してください。